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1 Introduction

Arducam now released an ESP32 based Arduino board for Arducam mini camera
modules while keeping the same form of factors and pinout as the standard Arduino
UNO R3 board. The high light this ESP32 board is that it well mates with Arducam
mini 2MP and SMP camera modules, supports Lithium battery power supply and
recharging and with build in SD card slot. It can be an ideal solution for home

security and IoT camera applications.

Figure 1 Arducam ESP32 UNO Kit

Features

Build in ESP-32S Module

26 digital input/output pins, 1O ports are 3.3V tolerant
Arducam Mini 2MP/5SMP camera interface

Lithium battery recharging 3.7V/500mA max
Building in SD/TF card socket

7-12V power jack input

Build in micro USB-Serial interface

vV V V ¥V V V V V N

Compatible with Arduino IDE
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3 Pin Definition
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Figure 2 Arducam ESP32 UNO Pin Out
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The board has build in Lithium battery charger, which accepts default

3.7V/500mA Lithium battery. The charging indicator and charging current setting can

be found from the Figure 3.
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Figure 3 Battery Charging Indicator and Current Settings
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4 Getting Started ESP32 with Arduino IDE

This chapter shows you how to develop an application for Arducam ESP32 UNO
board using Arduino IDE. (Tested on 64 bit Windows 10 machines)
4.1 Steps to install Arducam ESP32 support on Windows
» Starting Download and install the latest Arduino IDE Windows Installer from
arduino.cc
Download and install Git from https://git-scm.com

Start Git GUI and run through the following steps:
Select Clone Existing Repository:

& Git Gui - m| X

Repository Help

Create New Repository

|C|0r|e Existing Regositod

Cpen Existing Repository

Cuit

O

Select source and destination:

Figure 4 Select Clone Existing Repository

Source Location: https:/github.com/ArduCAM/ArduCAM_ESP32S UNO.git
Target Directory: C:/Users/[YOUR_USER_NAME]/Documents/Arduino/hardware/

ArduCAM/ArduCAM_ESP32S_UNO

Click Clone to start cloning the repository:

& GitGui o x
Repository Help

Clone Existing Repository

Source Location: |hrtps:j/github.comjArduCAM/ArduCAM_ESPSZS_UNO.git Browse
Target Direﬁory:!C;IUserszdminEslralorﬂ‘-- ts/Arduino/hardware/Ardul.  Browse
- Clone Type: Standard (Fast, Semi-Redundant, Hardlinks)

Full Copy (Slower, Redundant Backup)

Shared (Fastest, Not Recommended, No Backup)

Clone Quit

(4 Recursively clone submodules too

Figure 5 Clone the Repository
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Open C:/Users/[YOUR_USER NAME]/Documents/Arduino/hardware/

ArduCAM/esp32/tools and double-click get.exe

« Arduino > hardware » ArduCAM > ArduCAM_ESP325_UNO > tools v U EFwol. £ | (B HEECAUsers\Zk109\Documents\Arduinothardware\ArduCAM\ArduCAM ESP32S UNO\fools\get.exe

LI

g

partitions
sdk

2 build.py

[Z] common.sh

A espotaexe

# espotapy

2 esptoclpy

A gen_esp3Zpartexe

? gen esp32partpy

A getexe

= getpy

# platformio-build py

Figure 6 Install ESP32 board

When get.exe finishes, you should see the following files in the directory

<« Arduine > hardware » ArduCAM > ArduCAM_ESP325 UNO » tocls v o P
A e - A= el s
dist 2017
partitions 2
sdk 2
xtensa-esp32-elf 2
2 build.py K8

[Z] common.sh
A espotaexe 2
2 espota.py B
A esptaclexe 2
2 esptool.py 2
A gen_espa2part.exe 2
2 gen esp32partpy 2
A getexe

# get.py

2 platformio-build.py

Figure 7 ESP32 board directory
» Plug your ESP32 board and wait for the drivers to install (or install manually

any that might be required)
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4.2 Using Arduino IDE

After installation of Arducam ESP32UNO board, you can select this board from
the Tool->Board menu. And there several ready to use examples from the
File->Examples->ArduCAM. You can use these examples directly or as a starting
point to develop your own code.

» Start Arduino IDE, Select your board in Tools > Board menu>

ED sketch_jul17b | Arduine 1.8.0 - O e

File Edit Sketch Tools Help

i Auto Format Ctrl+T E
| Archive Sketch
sketch_jul17h Fix Encoding & Reload u

oid setup() Serial Monitor Ctrl+5hift+M =

7

put you  Serial Platter Curl +Shift+ L

WiFi101 Firmware Updater

Board: "ArduCAM ESP32S UNO"
Flash Frequency: "80MHz"
void loop() Upload Speed: "321600°

// put youl Port: "COMS"
Get Board Info

Vo v v

} Programmer: "ArduinolSP* >

Burn Bootloader

Figure 8 Board Selection

7 www.ArduCAM.com



Ardu@am

Arducam ESP

32 UNO Board User Guide

» Select the example from File->Examples->ArduCAM

&9 sketch_jul17a | Arduino 1.8.3

File Edit Sketch Toaols Help

Mew

Open...

Open Recent
Sketchbook
Examples
Clase

Save

Save As...

Page Setup
Print

Preferences

Quit

[nvalid libra

[rnvalid library

[nvalid lib

Ctrl+N
Ctrl+0

Ctrl+W
Ctrl+5
Ctrl+5Shift+5

Ctrl+Shift+P

Ctrl+P

Ctrl+Comma

Ctrl+Q

ound in
ound in

found in

Ds3231

Ethernet

Firmata

Humiino

ILI9486 Test
ITEADLIB Arduino ESPB266-master
Keypad

LCD 1602 RUS

LedControl

LiquidCrystal
LiquidCrystal 12C
LiquidCrystal_I12C-master
MPUBDS0

MNewPing

so

$11143_Pulse Prox_Sensoars
SoftSPl

Stepper

Temboo

TET

Usglib

WiFi

Examples for ArduCAM ESP325 UNO
ArduCAM

Arducam ESP32 TVOC
ArducamSSD1306
ArduinoOTA

Figure 6 Example Selection

» Configure the camera setting

>;“

¢

i

>

i ESP32 : ArduCAM _ESP32 Capture
S ArduCAM ESP32 Capture25D
» J ArduCAM_ESP32 Sleep
e ArduCAM ESP32 Video25D

You need to modify the memorysaver.h file in order to enable OV2640 or

OV5642 camera for ArduCAM Mini 2MP or 5SMP camera modules. Only one

camera can be enabled at a time. The memorysaver.h file is located at

C:\Users\[YOUR_USER_NAME]\Documents\Arduino\hardware\ ArduCAM

\ArduCAM_ESP32S UNO\libraries\ArduCAM

//Step 1: select the hardware platform,
Edetine ovZ2ed0 MINT JMp |

//#define OV5642 MINI 5SMP

//#define OV5642 MINI 5MP BIT ROTATION F
//#define OV5642 MINI 5MF PLUS

//#define OV5640 MINI 5MP FLUS

//#define
//#define

ARDUCEM SHIELD REVC
ARDUCAM SHIELD V2

Figure 7 Camera Configuration
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» Compile and uploading
Click uploading the example will automatically flashed into the board.
4.3 Examples
There are 4 examples for both 2MP and SMP ArduCAM mini camera modules.
» ArduCAM ESP32 Capture
This example uses HTTP protocol to capture still or video over home wifi
network from ArduCAM mini 2MP/5SMP and display on the web browser.
The default is AP mode, after uploading the demo, you can search the
‘arducam_esp32’and connect it without password.

€8 ArduCAM_ESP32 Capture | Arduino 1.8.3 a5 O x
Fle Edit Sketch Tools Help

ArduCAM_ESP32_Capture

//Default is AP mode.
int wifiType = 1: // 0:Station 1:AP

J /AP mode configuration

[/Default is arducam esp8266. If wou want, vou can change the AP aaid to vour f
const char *#AP ssid = "arducam esp32”:

J/Default is no password. If yvou want to set password, put vour password here

const char *AP password = NILL:

J//Station mode wou should put your ssid and password
const char *ssid = “SSID”: // Put vour S5S5ID here
const char *password = "PASSWORD™: // Put vour PASSWORD here

Figure 8 Mode Configure
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€9 comg = X

Send

1k drv:0x00, g drv:0=x00, d_drv:0=x00, cs0 _drv:0x00, hd drv:0x00, wp_drv:0x 4
node:DI0, clock div:l

load:0x3f££0008, len: s

load:0x3£££0010, len: 20164

Load:0x40078000, len: 7780

10 0 tail 12 room 4

Load:0x40080000, len:252

antry 0x40080034

YrduCAN Start!

V2640 detected.

share AP: arducam esp3Z2

[he password is: \
192, 165. 4.1
server starte:\

< >

[+] Autozerall Mo line ending =~ | [115200 baud =+ Clear output

Figure9 Identifying IP address

If you want to use STA mode, you should change ‘int wifiType = 1’ to ‘int

wifiType =0’.The ssid and password should be modifies before uploading.
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€8 ArduCAM ESP32 Capture | Arduino 1.8.3 = O =
file Edit Sketch Tools Help

ArduCAM_ESP32_Capture §

gendif

J/vou can change the value of wifiTvpe to select Station or AP mode.
J/Default is AP mode.
int wifiType = 0f // 0:Station 1:AP

//AP mode configuration

[//Default is arducam esp8266.If you want, you can change the AP_aaid to:
const char *AP ssid = "arducam esp32”;

J/Default is no password. If vou want to set password, put vour password h

const char *AP password = NULL;

//Station mode vou should put vour ssid and password
bonst char *ssid = “SSID”; // Put vour SSID here
-onst char *password = "PASSWORD”: // Put vour PASSWORD here

Figure10 Wifi Camera Example
After uploading, the board IP address is obtained via DHCP protocol. You can
figure out the IP address through the serial monitor as Figure 10 shown. The default

serial monitor baudrate setting is 115200bps.
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£ coms - o X

H Send |

rid | EH 1 <l H o Mool o SRl LagE 48 = g e 1ELA
V2640 detected h‘

Connecting to 3A0F1F1-10327F

... TiF1 commected

192.168.0.8

Berver started

< IS

/"-_—-\\’\v
]
Autascro].l Nl ‘Hu line ending v| IIIEZUU ha?g;

Figure 10 Identifying IP address

Finally, open the index.html , input the IP address obtained from the serial

monitor then take pictures or videos. The html files are located at

C:\Users\[YOUR_USER NAME]\Documents\Arduino\hardware\ArduCAM\ArduCAM_ESP32S UNO

\libraries\ArduCAM\examples\ESP32\ArduCAM_ ESP32 Capture\html

ArduCAM_OV2640 Video

Camera IP Address

192.168.4.1

160X120 176X144 320%240 352X288 640X480
B800X600 1024X768 1280X1024 1600X1200

Figure 11 Example Html page

» ArduCAM_ESP32 Capture2SD
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This example takes time elapse still photos using ArduCAM mini 2MP/5MP

and then stored on the TF/SD card. The LED indicates when the TF/SD card is

writing.

-
el
e
ArduCAM ESP32 Cap

ture_Demo. avi

€2 comg

Send

load:0x3£f£0008, len: B
load:0x3f££0010, len: 2016
load:0x40078000, len: 7780
ho 0 tail 12 room 4
load:0x40080000, len: 252
entry 0x40080034
ArduCAN Start!

5D Card detected!

3D Card Tvpe: SDHC

5D Card Size: ToBOMB
OV2E40 detected.

Star Capture

Capture Done.

The fifo length is :6148
Image save QK.

Star Capture

Capture Done.

The fifo length 1s :6148
<

>

Autoscroll

Figure 12 Example

Ho line ending -

» ArduCAM_ESP32 Video2SD

115200 bhaud Clear output

ArduCAM_ESP32 Capture2SD

This example takes motion JPEG video clips using ArduCAM mini 2MP/5MP and

then stored on the TF/SD card as AVI format.

13
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€ comg = X

Il Send

configsip: 0, SPIWP:0x00
clk_drv:0x00, g drv:0x00, d_drv:0z00, cs0_drv:0=x00, hd_drv:0z00, wp_drv:0=
mode:DI0, clock div:l

load:0x3f£f0008, len: 8

load:0x3f££f0010, len: 2016

load:0x40078000, len: 7780

ho 0 tail 12 room 4

load:0x40080000, len: 252

entry Ox40080034
ArduCAN Start!

5D Card detected!
DV2640 detectead,
3D Card Tvpe: SDHC
5D Card Size: T7580MB

ecording video, please walt...
Record video 0K

Recording video, please walt...

< >

[+] Autoserall Mo line ending -+ | 115200 baud - Clear output

Figure 13 Example ArduCAM ESP32 Video2SD
» ArduCAM_ESP32 Sleep
To reduce power consumption,calling the interface function immediately goes into the
Deep - sleep mode.In this mode, the chip will disconnect all wi-fi connections and
data connections and enter the sleep mode. Only the RTC module will still work and

be responsible for the timing of the chip. This demo is suitable for battery power
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Figure 14 Normal mode

Figure 15 DeepSleep mode
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SD Card detected!

5D Card Type: SDHC

oD Card Size: 7H80MB
JV2640 detected.

Star Capture

Capture Done.

The fifo length is :7172
Image =save OE.

ets Jun 8§ 2016 00:22:57

rst:0x5 (DEEPSLEEP_RESET), boot:0x13 (SPI_FAST_FLASH BOOT)

configsip: 0, SPIWP:0=00

cllk drv:0z00, g drv:0z00, d drv:0z00, cs0_drv:0x00, hd_drv:0x00, wp_drv:0x
mode:DI0, clock diwv:l

load:0x3ff£0008, len: 8

load:0x3£££0010, len: 2016

1load:0x40078000, len: 7780

ho 0 tail 12 room 4
< >

Figure 16 Example ArduCAM_ESP32 Sleep

16 www.ArduCAM.com



