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Changes from v1.5 to v1.6

Setup commands MU and MW were added to provide an MQTT username and password.

Overview
The ESP32LR20 is a WIFI connected relay module using the popular ESP32.

It provides 2 relays capable switching up to 16 Amps. The normally open relay contacts have snubbers
fitted across them, and can drive inductive loads such as contactors and solenoids.

Power for the board is 12v dc, which can be provided by a standard universal wall power supply. A 1A
or greater supply should be selected.

Control Protocols

1. Simple plain text commands sent to the module.
2. HTML commands

3. MQTT

4. A built in webpage

WiFi
The ESP32LR20 connects via 2.4GHz WiFi to your network. Therefore it must be located in a position

where it gets a good WiFi signal. The module should not be enclosed in a metal box/cabinet as this will
shield the WiFi signal.

You can check the signal level by looking at the RSSI figure which is reported by the ST (STatus)
command.

Configuration

The ESP32LR20 is configured by connecting a USB cable to your PC and running a terminal program.
PuTTY is a good option if you don’t have any other preferences.

The serial port should be set to 115200 baud, 8 bit, 1 stop, no parity, no flow control.
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USB Configuration Commands

ST Status. Return the system status

Status:

Firmware Version: 1.6

IP: 0.0.0.0 (192.168.0.19)
Subnet: 0.0.0.0

Gateway: 0.0.0.0

Primary DNS: 0.0.0.0
Secondary DNS: 0.0.0.0
Password: ****x*xx*
ASCII TCP Port: 17123
RSSI: -72

MQTT Server: 192.168.0.115
MQTT Port: 1883

MQTT ID: ESP32LR20
MQTT User: myUsername
MQTT Password: ****x*xxx*
Relayl Topic: R1Topic
Relay2 Topic: R2Topic

When the IP address is set to 0.0.0.0 this means that the IP address is being provided by
your networks DHCP server. In that case the assigned IP address is also provided, as
above.

When the SSID and Password are setup, they will be displayed until the next reset, After
that they will only show as *******x*,

RB ReBoot

This will restart the module. It may produce a lot of random characters as the
ESP32’s boot logging runs at a different baud rate. If it succeeds in connecting to your
network it will report the IP address.

Re-Booting.. .

WiFi connected.
IP address:
192.168.0.6
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IP Sets the modules IP address

Enter IP followed by the required IP address. Entering address 0.0.0.0 means the IP will be
obtained from your networks DHCP server. The new IP address will take effect after the
next re-boot.

IP "192.168.0.123"
OK. Saved IP Address: 192.168.0.123

SB Sets the SuBnet mask

SB “255.255.255.0”
OK. Saved Subnet Mask: 255.255.255.0

GW Sets the GateWay address

This is normally the IP address of your router.

GW "192.168.0.1"
OK. Saved Gateway Address: 192.168.0.1

PD Sets the Primary DNS

The can be the IP address of your router which will then use your ISP provided DNS.
You can also specify the DNS such as 8.8.8.8 for Googles DNS server.

PD "192.168.0.1"
OK. Saved Primary DNS: 192.168.0.1

SD Sets the Secondary DNS

The can be the IP address of your router which will then use your ISP provided DNS.
You can also specify the DNS such as 8.8.4.4 for Googles DNS server.

SD “8.8.4.4"
OK. Saved Secondary DNS: 8.8.4.4
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SS This sets the SSID

The SSID is the public name of your WIFI network Enter your WIFI's SSID here.

SS “Devantech”
OK. Saved SSID: Devantech

PW Sets your networks WIFI password

PW "K]~kCZUV*UGA6SG~"
OK. Saved Password: K]~kCZUV*UGA6S5G~

PA Sets the TCP/IP port number for the ASCIl commands

PA 17126
OK. Saved ASCII port number: 17126

AP Sets the ASCII password

AP "MySecretPassword"
OK. Saved AsciiPassword: MySecretPassword

MS Sets the MQTT broker address

MS %192.168.0.121"
OK. Saved MQTT Server: 192.168.0.121

MD Sets the MQTT ID for this module

MS “UniqueModuleName”
OK. Saved MQTT ID: UniqueModuleName

Copyright © 2021, Devantech Ltd.
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MP Sets the MQTT broker’s port

Normally, this should be set to 1883.

mp 1883
OK. Saved MQTT port number: 1883

If you are not using MQTT, set the port to 0. This will turn off MQTT, otherwise it will continuously
try to connect if there is no MQTT broker.

MU Sets the MQTT user name (V1.6+)

This is for MQTT brokers that are setup to require a username and password. For open MQTT
brokers that do not require a user name/password, these may be ignored.

MU “*myUsername”
OK. Saved MQTT User: myUsername

MW Sets the MQTT password (V1.6+)

This is for MQTT brokers that are setup to require a username and password.

MW “mySuperSecretPassword”
OK. Saved MQTT Password: mySuperSecretPassword

R1-R2 Sets the MQTT topic this relay is subscribed to

R2 "Workshop/Heater"
OK. Saved Relay 2 Topic: Workshop/Heater

In use, the payload for relay topics should be a string with the first character set to ‘0’ or ‘1’
(ASCII characters 0x30/0x31).
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TCPI/IP Commands

The ESP32LR20 has a built in TCP/IP command set which allows you to control the module
remotely.

All commands are sent using plain ASCII text. PUTTY is a good cross platform terminal program to
use for testing. The TCP/IP port is the one you set-up with the PA command during USB
configuration. Do not use port 80 as that is reserved for the HTML commands and Webpage.

SR Set Relay

This is used to turn a relay on or off

To turn Relay 1 on:
SR11

The first number is the relay number from 1 to 2.
The second number is 1 or 0, on or off.

So turn turn relay 1 off again:

SR10

The command will respond with ok or fail.

SR11
ok

SR16
fail < 6 is not valid, only 1 or O for on/off

SR91
fail < relay 9 does not exist.

GR Get Relay

Will return the state of the relay.

To get the status of relay 2:
GR 2
1

GR 2
0

GR 9
fail < relay 9 does not exist.
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Password

From version 1.5 we have added a password to the ASCII commands, this can be set with the AP
command over the USB connection. The password is passed as a prefix to any command.

For example if a password is set and relay 1 is required to be turned on, start with the password
(example password of 1234), then the command, so it becomes:

1234SR 11

HTML Commands

There are a set of HTML commands that can be used to control the module.
?Rly2=1 This will turn on relay 2

?Rly2=0 This will turn off relay 2

?Rly2=2 This will toggle relay 2 to the opposite state.

You can enter the commands into a browser immediately after the IP address.

http://192.168.0.3/?Rly2=1

This will turn on relay 2.
In response the module will return an XML file, which your browser will display.

<ESP32LR20DATA>
<RELAYS>
<RLY1>off</RLY 1>
<RLY2>on</RLY?2>
</RELAYS>
</ESP32LR20DATA>

The XML file is generated after the command has executed, therefore will reflect the new status of
the relays.
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Webpage

The built in webpage can be used as a remote app to monitor and control the relays. Your can
access the page as a default with just the IP address or by specifying index.htm.

¢ %.495%010:12

ESP32LR20 0
192.168.0.19

ESP32LR20

Relay 1 Relay 2

The webpage contains the Javascript to send an HTML toggle command, as described in the
previous section. It will send the toggle command each time a button is clicked. It then uses the

responding XML file to colour the buttons.
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Schematics

CPU
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- 50 3IoUT 3 USB-MINI-B
35 3 Tx VeclOo T
Rx Rst
1
12 =] Vee
2 oM m 3 USBDM
- RTS oP r USBDP
DTR . — D
Gnd 5 = Ground
Gnd
FT231% C3 @
100n |
| J—
25 T
3
1
15 R56
£ 120
39

SW1
—

o O
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Reset

The CPU schematic is the same for the ESP32L.R20, ESP32L.LR42 and ESP32L.R88.
Relays 3-8 and Inputs 1-8 are not available on the ESP32LR20
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Relay Outputs

1 of 2 identical circuits shown

S ooeme P4SMA440CA
FEC 2458385 or squiv FEC 189120 or equiv v
\
\ / RL1 R22
Ji L c7 V4
g 2 23n VS .
r ZN D1
° / ° g S1G SZ&I L2
LED
3 | -
] 54 RLY-SFCO
y -
400v T50mW
2010 footprint

The relays are capable of switching up to 16 Amps at 24vdc or 230vac. A data sheet of the relay can be
found here. Only the normally open (N/O) contact has the snubber circuitry.
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PCB dimensions
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Appendix 1
Programming the ESP32LR20 with Arduino studio

Customising the ESP32LR20 can easily be achieved by using the Arduino studio and importing the
required libraries.

Step 1 — Arduino IDE installation
Obtain and install the latest Arduino IDE from https://www.arduino.cc/en/Main/Software it should be

the latest to ensure compatibility.
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: www.robot-electronics.co.uk 1 5
All rights reserved.



http://www.robot-electronics.co.uk/
https://www.arduino.cc/en/Main/Software

ESP32LR20

Step 2 — Add the ESP32 library URL to the Arduino IDE
Go to File>Preferences
Now in the Preferences screen below we need to enter

https://dl.espressif.com/dl/package esp32_index.json

User Manual v1.6

into the “Additional Board Manager URLs” option. If you already have libraries added you may need

to add a comma between the URLs

Preferences

settings  Metwork

Sketchbook location:

Ci\Usersdesign 1'\Documents \Arduino

Editor font size: 12
Interface scale: Automatic | 100 I % {requires restart of Arduing)
Theme: Default theme -+ | ({requires restart of Arduino)
Show verbose output during: [ ] compilation  [] upload
Compiler warnings: Mone

[] Display line numbers

[[] Enable Code Folding

Verify code after upload

[[] Use external editor

Aggressively cache compiled core

Check for updates on startup

Update sketch files to new extension on save (.pde -> .ino)

Save when verifying or uploading

Editor language: System Default «w | (reguires restart of Arduino)

Browse

(.ﬁ.ddiﬁnnal Boards Manager URLs: |htips:f/dl.espressif,com/dlfpackage_esp32_index.json

Maore preferences can be edited directly in the file

C:\U=zers'design1\Documents\ArduinoData \preferences, tut

Men Arguino s not runmng

OK

Cancel

You can now click the OK button to finish with this screen.

Copyright © 2021, Devantech Ltd.
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Step 3 — Install the ESP32 library
Go to Tools>Board:>Boards Manager...

@ ESP32LR42 | Arduine 1.8.% (Windows Store 1.8.21.0)
File Edit Sketch Tools Help

ESP32LR42

#include <Pre
#include <WiF

CORSt char ve

Preferences nij

IPAddress
IPAddress
IPAddress
IPRddress
IPAddres=ss

Copyright © 2021, Devantech Ltd.
All rights reserved.

loc
gat!
suk
Prl
seq)

Auto Forrmat

Archive Sketch

Fix Encoding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter

WIFi101 / WiFiMINA Firmware Updater

Processor "ATmegal23P"
Port
Get Board Info

Programmer: "AVRISP mikll"

Burn Bootloader

Ctrl+T

Ctrl+5Shift+|
Ctrl+5hift+ M
Ctrl+5Shift+L
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Now filter by “esp32” and install the Espressif Systems library

@ Boards Manager

Type .AJ] w :esﬁSE

esp32 by Espressif Systems

Boards included in this package:
ESP2Z Dev Module, WEMOS LoLin32.
More info

1.0.2 ~ || Instal

Close
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Step 4 — Board selection

Go to Tools>Board:> and select ESP32 Dev Module

Copyright © 2021, Devantech Ltd.
All rights reserved.

Arduino ARM (32-bits) Boards
Arduino Due (Programming Port)
Arduino Due (Mative USE Port)
ESP32 Arduino

ESP3Z Dev Module

ESP32 Wrowver Module

E5SP32 Pico Kit
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Step 5 — Add MQTT library
Go to Tools>Manage Libraries...
Filter by PubSubClient and select PubSubClient by Nick O’Leary, then press the install button

'E' Library Manager

Type Al ~ | Topic |Al " fPubSubCIient

munet by Dominik Schldsser, Leo Moll

Modules for WLAN-Client, NTP, OTA, MQTT on ESP22/ESP3266 compatible with muwerk scheduler Modules for WLAN-Client, NTP,
OTA, MOQTT on ESP22/ESPE266 compatible with muwerk scheduler, requires libraries ustd, muwerk, Arduinolson and PubSubClient.
Mare info

PubSubClient by Nick O'Leary Version 2.7.0 INSTALLED

A dlient library for MQTT messaging. MQTT is a lightweight messaging protocol ideal for small devices. This library allows you to
send and receive MQTT messages. It supports the |latest MQTT 2.1.1 protocol and can be configured to use the older MQTT 3.1 if
neaded. It supports all Arduino Ethernet Client compatible hardware; including the Intel Galileo/Edison, ESPEZ266 and TI CC2000.
Mare info

Install

PubSubClientTools by Simon Christmann

Tools for easier usage of PubSubClient Provides useful tools for PubSubClient, however they may consume more power and
storage. Therefore it's recommended for powerful microcontrollers like ESPE266,

Maore info

Close

That’s it! Your Arduino IDE should now be able to program the ESP32LR20 module. The factory
shipped code is available Here: https://github.com/devantech
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Notes
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