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Changes from v1.5 to v1.6

Setup commands MU and MW were added to provide an MQTT username and password.

Overview
The ESP32LR42 is a WIFI connected relay module using the popular ESP32.

It provides 4 relays capable switching up to 16Amps and 2 digital inputs with pull-ups than can
interface directly with volt free contacts. The normally open relay contacts have snubbers fitted across
them, and can drive inductive loads such as contactors and solenoids.

Power for the board is 12v dc, which can be provided by a standard universal wall power supply. A 1A
or greater supply should be selected.

Control Protocols

1. Simple plain text commands sent to the module.
2. HTML commands

3. MQTT

4. A built in webpage

WiFi
The ESP32LR42 connects via 2.4GHz WiFi to your network. Therefore it must be located in a position
where it gets a good WiFi signal. The module should not be enclosed in a metal box/cabinet as this will

shield the WiFi signal.
You can check the signal level by looking at the RSSI figure which is reported by the ST (STatus)

command.

Configuration

The ESP32LR42 is configured by connecting a USB cable to your PC and running a terminal program.
PuTTY is a good option if you don’t have any other preferences.

The serial port should be set to 115200 baud, 8 bit, 1 stop, no parity, no flow control.
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USB Configuration Commands

ST Status. Return the system status

Status:

Firmware Version: 1.2

IP: 0.0.0.0 (192.168.0.30)
Subnet: 0.0.0.0

Gateway: 0.0.0.0

Primary DNS: 0.0.0.0
Secondary DNS: 0.0.0.0
Password: ****x*xx*
ASCII TCP Port: 17123
RSSI: -66

MQTT Server: 192.168.0.115
MQTT Port: 1883

MQTT ID: ESP32LR42
MQTT User: myUsername
MQTT Password: ****x*xxx*
Relayl Topic: R1Topic
Relay2 Topic: R2Topic
Relay3 Topic: R3Topic
Relay4 Topic: R4Topic
Inputl Topic: InputlTopic
Input2 Topic: Input2Topic

When the IP address is set to 0.0.0.0 this means that the IP address is being provided by
your networks DHCP server. In that case the assigned IP address is also provided, as
above.

When the SSID and Password are setup, they will be displayed until the next reset, After
that they will only show as ******xx*,

RB ReBoot

This will restart the module. It may produce a lot of random characters as the
ESP32’s boot logging runs at a different baud rate. If it succeeds in connecting to your
network it will report the IP address.

Re-Booting.. .

WiFi connected.
IP address:
192.168.0.6
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IP Sets the modules IP address

Enter IP followed by the required IP address. Entering address 0.0.0.0 means the IP will be
obtained from your networks DHCP server. The new IP address will take effect after the
next re-boot.

IP “192.168.0.123"
OK. Saved IP Address: 192.168.0.123

SB Sets the SuBnet mask

SB “255.255.255.0”
OK. Saved Subnet Mask: 255.255.255.0

GW Sets the GateWay address

This is normally the IP address of your router.

GW "192.168.0.1"
OK. Saved Gateway Address: 192.168.0.1

PD Sets the Primary DNS

The can be the IP address of your router which will then use your ISP provided DNS.
You can also specify the DNS such as 8.8.8.8 for Googles DNS server.

PD "192.168.0.1"
OK. Saved Primary DNS: 192.168.0.1

SD Sets the Secondary DNS

The can be the IP address of your router which will then use your ISP provided DNS.
You can also specify the DNS such as 8.8.4.4 for Googles DNS server.

SD “8.8.4.4"
OK. Saved Secondary DNS: 8.8.4.4
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SS This sets the SSID

The SSID is the public name of your WIFI network Enter your WIFI's SSID here.

SS “Devantech”
OK. Saved SSID: Devantech

PW Sets your networks WIFI password

PW "K]~kCZUV*UGA6SG~"
OK. Saved Password: K]~kCZUV*UGA6SG~

PA Sets the TCPIIP port number for the ASCIl commands

PA 17126
OK. Saved ASCII port number: 17126

AP Sets the ASCII password

AP "MySecretPassword"
OK. Saved AsciiPassword: MySecretPassword

MS Sets the MQTT broker address

MS %192.168.0.121"
OK. Saved MQTT Server: 192.168.0.121

MD Sets the MQTT ID for this module

MS “UniqueModuleName”
OK. Saved MQTT ID: UniqueModuleName

MP Sets the MQTT broker’s port

Normally, this should be set to 1883.

mp 1883
OK. Saved MQTT port humber: 1883

Copyright © 2021, Devantech Ltd.
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If you are not using MQTT, set the port to 0. This will turn off MQTT, otherwise it will continuously
try to connect if there is no MQTT broker.

MU Sets the MQTT user name (V1.6+)

This is for MQTT brokers that are setup to require a username and password. For open MQTT
brokers that do not require a user name/password, these may be ignored.

MU “*myUsername”
OK. Saved MQTT User: myUsername

MW Sets the MQTT password (V1.6+)

This is for MQTT brokers that are setup to require a username and password.

MW “mySuperSecretPassword”
OK. Saved MQTT Password: mySuperSecretPassword

R1-R4 Sets the MQTT topic this relay is subscribed to

R3 "Workshop/Heater"
OK. Saved Relay 3 Topic: Workshop/Heater

In use, the payload for relay topics should be a string with the first character set to ‘0’ or ‘1’
(ASCII characters 0x31/0x30).

N1-N2 Sets the MQTT topic this Input will publish to

N2 "Workshop/Heater"
OK. Saved Input 2 Topic: Workshop/Heater

The payload generated for input topics is a string with the first character set to ‘1’ if the input is
open or unconnected, and ‘0’ if the input pins are shorted. (ASCII characters 0x31/0x30).
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TCPIIP Commands

The ESP32LR42 has a built in TCP/IP command set which allows you to control the module
remotely.

All commands are sent using plain ASCII text. PUTTY is a good cross platform terminal program to
use for testing. The TCP/IP port is the one you set-up with the PA command during USB
configuration. Do not use port 80 as that is reserved for the HTML commands and Webpage.

SR Set Relay

This is used to turn a relay on or off

To turn Relay 1 on:
SR11

The first number is the relay number from 1 to 8.
The second number is 1 or 0, on or off.

So turn turn relay 1 off again:

SR10

The command will respond with ok or fail.

SR11
ok

SR16
fail < 6 is not valid, only 1 or O for on/off

SR91
fail < relay 9 does not exist.

Copyright © 2021, Devantech Ltd.
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GR Get Relay

Will return the state of the relay.
To get the status of relay 3:

GR 3

1

GR 3
0

GR 9
fail < relay 9 does not exist.

Gl Get Input

Will return the status of an input.

GI 2

0 Input 2 is low (Green Led is on)
GI 2 Input 2 is high (Green Led is off)
1

GI9

fail Only 2 inputs available

AL Get All 2 inputs

AL
10 Here, Input 2 is low, all others are high.

Inputs are numbered from left to right, 1 to 2.

Password

From version 1.5 we have added a password to the ASCII commands, this can be set with the AP
command over the USB connection. The password is passed as a prefix to any command.

For example if a password is set and relay 1 is required to be turned on, start with the password
(example password of 1234), then the command, so it becomes:

1234SR 11

Copyright © 2021, Devantech Ltd. .
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HTML Commands

There are a set of HTML commands that can be used to control the module.

?Rly3=1 This will turn on relay 3
?Rly3=0 This will turn off relay 3
?Rly3=2 This will toggle relay 3 to the opposite state.

You can enter the commands into a browser immediately after the IP address.

http://192.168.0.3/?Rly3=1

This will turn on relay 3.
In response the module will return an XML file, which your browser will display.

<ESP32LR42DATA>
<RELAYS>
<RLY1>off</RLY1>
<RLY2>on</RLY2>
<RLY3>on</RLY3>
<RLY4>on</RLY4>
</RELAYS>
<INPUTS>
<INP1>1</INP1>
<INP2>0</INP2>
</INPUTS>
</ESP32LR42DATA>

The XML file is generated after the command has executed, therefore will reflect the new status of
the relays.

Copyright © 2021, Devantech Ltd.
All rights reserved.
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Webpage

The built in webpage can be used as a remote app to monitor and control the relays. Your can
access the page as a default with just the IP address or by specifying index.htm.

T+ 7 %.4100%211:04
X o3 1e8050" o
ESP32LR42
Relay 1 Relay 2
Relay 3 Relay 4

Inputs1 ® @2

The webpage contains the Javascript to send an HTML toggle command, as described in the
previous section. It will send the toggle command each time a button is clicked. It then uses the
responding XML file to colour the buttons and set the Input buttons to indicate input status.
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M1
RLY1 = cross 203 J
RLY2 2 criozs
RLY3 GFIOZ8
rLvs O g GRIOZ7
RLYS 2 crios A
RLYE e s IC2
RLY7 12 Griot3
rLve O—23t Grio2 vee |2 PL1
3V30UT =
) R E Vealo |—2 USB-MIN-E
INP1 O—:a GFIO4 ™ 2 2 Ax Rst |—%
ez O 2L ] Grios 2 ;— Vee
INP2 E GPIO17 5 DM 1? =] useom
NP4 GFIOS 21 aTs DF USBDF
INFS :E GFID18 DTR . e )
INF& GPID18 Gnd £ Ground
INFT E GFID21 Gnd |2
-
INFB GPIDZ2 — o3 o
L11 100n
R35 N
—1 a7 -
{ ] % 21 Grioz3 :
k 2 criots |
ﬁ - GPO32
G 5— GPI35 —
= Gri E
= Griag
— Grizs -
GPion =2
T =
GND1 |t R56
enp2 (12
GND3 120
GND4 |22 SW1
; 1
L O O—
E5Faz _ FUSH-SWITCH |
Reset -
Note.

The CPU schematic is the same for the ESP32L.R20, ESP321.R42 and ESP32L.R88.

Relays 5-8 and Inputs 3-8 are not available on the ESP32LR42.
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uz VeelD Sv U1
XCE2108332MR XCEZ10B332MR A
VIN  vouT =2 —{vin__vouT £ ’
SHODN SHDN
e C21 C13 =s c1i c17
2 1 :uu=—|_ 10 uF—|_ 2 1C-uF—|_ oF |
- IC1 By
? BOOTO3FF 110 A
47uH
DC CONNECTOR - R65
CON1 2K2
+| 100uUF sMmT
Y B ‘U = =C18 _
il I N D18 14 = C19 59 1 20
SMJ15 100UF SMT
N, D17 4 .| 100uF smT
- L19
- Blues
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Relay Outputs

1 of 4 identical circuits shown

830w COGMPO ShA ca
A
\ / RL1 R22
Ji —L_c7 V4
g - 33n VS N
r ZS D1
° / ° g S16G SZ&N L2
| _ LED
] 543 RLY-SPCO
400w 7HOm W
2010 footprint

The relays are capable of switching up to 16 Amps at 24vdc or 230vac. A data sheet of the relay can be
found here. Only the normally open (N/O) contact has the snubber circuitry.

Copyright © 2021, Devantech Ltd.
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Digital Input

1 of 2 identical circuits shown

R68
= [] RE7
47
120
PL10 GRN
O
o1
TERMZ

Digital Inputs have a pull-up resistor to 3.3v and will operate with a simple contact closure to ground.

Alternatively, they may be connected to 3.3v logic. The clamping diodes prevent operation at voltages
higher than 3.3v, so don’t connect to 5v logic.
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Appendix 1
Programming the ESP32LR42 with Arduino studio

Customising the ESP32LR42 can easily be achieved by using the Arduino studio and importing the
required libraries.

Step 1 — Arduino IDE installation
Obtain and install the latest Arduino IDE from https://www.arduino.cc/en/Main/Software it should be
the latest to ensure compatibility.

Copyright © 2021, Devantech Ltd.
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Step 2 — Add the ESP32 library URL to the Arduino IDE
Go to File>Preferences

Now in the Preferences screen below we need to enter
https://dl.espressif.com/dl/package esp32 index.json

into the “Additional Board Manager URLs” option. If you already have libraries added you may need

to add a comma between the URLs

Preferences #
Settings  Netwark
Sketchbook location:
C:_'nJ_.Isers 'n,clesi_gnl'n,Dnmments ‘Arduino Browse
Editor language: System Default w | (reguires restart of Arduing)
Editor font size: 12
Interface scale: Automatic | 100 I % {requires restart of Arduing)
Theme: Default theme - | (requires restart of Arduino)
Show verbose output during: [ | compilation [ upload
Compiler warnings: |Mone
[] Display line numbers
[[] Enable Code Folding
Verify code after upload
[] Use external editor
Aggressively cache compiled core
Check for updates on startup
Update sketch files to new extension on save (.pde -> .ino)
Save when verifying or uploading
(.ﬁ.ddit'onal Boards Manager URLs: ht_h:ns:,.",.’f:ll.gspresgif.cnm,ridlfpadcage_n_asp32_index.jsnn ﬁ)
Mare preferences can be edited directly in the file
C:\Usersidesignl\Documents\ArduinoData \preferences. bt
(edit only when Arduing is not running)
Ok Cancel

You can now click the OK button to finish with this screen.

Copyright © 2021, Devantech Ltd.
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Step 3 — Install the ESP32 library
Go to Tools>Board:>Boards Manager...

@ ESP32LR42 | Arduine 1.8.9 (Windows Store 1.8.21.0)
File Edit Sketch Tools Help

ESP32LR42

#inclnude <Pre
#include <WiF

Cconst char ve

Preferences I

IPAddress loc

IPAddress gat
IPAddress sub
IFAddress pri
IPAddress 3eC

Auto Forrat

Archive Sketch

Fix Encoding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter

WIFI101 / WiFiNINA Firmware Updater

Processor "ATmega328P"
Port
Get Board Info

Programmer: "AVEISP mbkdl"

Burn Bootloader

Ctrl+T

Ctrl+5Shift+|
Ctrl+5hift+M
Ctri+5hift+L

User Manual v1.6

£

Sl

aar

Copyright © 2021, Devantech Ltd.
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Now filter by “esp32” and install the Espressif Systems library

@ Boards Manager

Type .AJ] w :esﬁSE

esp32 by Espressif Systems
Boards included in this package:

ESP2Z Dev Module, WEMOS LoLin32.
More info

1.0.2 ~ || Instal

Close

Copyright © 2021, Devantech Ltd. .
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Step 4 — Board selection

Go to Tools>Board:> and select ESP32 Dev Module

Copyright © 2021, Devantech Ltd.
All rights reserved.
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Arduino Due (Programming Port)
Arduino Due (Mative USE Port)
E5P32 Arduino

ESP3Z Dev Module

ESP32 Wrover Module

ESP32 Pico Kit

www.robot-electronics.co.uk

User Manual v1.6

21


http://www.robot-electronics.co.uk/

ESP32LR42 User Manual v1.6

Step 5 — Add MQTT library
Go to Tools>Manage Libraries...
Filter by PubSubClient and select PubSubClient by Nick O’Leary, then press the install button

'E' Library Manager

Type Al ~ | Topic |Al " fPubSubCIient

munet by Dominik Schidsser, Leo Moll

Modules for WLAN-Client, NTP, OTA, MQTT on ESP22/ESP3266 compatible with muwerk scheduler Modules for WLAN-Client, NTP,
OTA, MOQTT on ESP22/ESPE266 compatible with muwerk scheduler, requires libraries ustd, muwerk, Arduinolson and PubSubClient.
Mare info

PubSubClient by Nick O'Leary Version 2.7.0 INSTALLED

A client library for MQTT messaging. MQTT is a lightweight messaging protocol ideal for small devices. This library allows you to
send and receive MQTT messages. It supports the |latest MQTT 2.1.1 protocol and can be configured to use the older MQTT 3.1 if
neaded. It supports all Arduino Ethernet Client compatible hardware, including the Intel Galileo/Edison, ESPEB266 and TI CC2000.
Mare info

Install

PubSubClientTools by Simon Christmann

Tools for easier usage of PubSubClient Provides useful tools for PubSubClient, however they may consume more power and
storage. Therefore it's recommended for powerful microcontrollers like ESPE266,

Maore info

Close

That’s it! Your Arduino IDE should now be able to program the ESP32L.R42 module. The factory

shipped code is available Here: httQS:/ / github.com/ devantech
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